Export buttons remain clickable after editor form opens.

Export buttons remain clickable after editor form opens.

zodiacszodiacs Posts: 10Questions: 1Answers: 0
edited April 2015 in TableTools

Hey,

First of all, hello to everyone in this forum.
I am now using dataTables and Editor for about 1 month and i am just delighted on the functions and implementation of it. Thank you very much, great job. It saves me hours op programming.

Unfortunately now i have a little problem and after searching here in the forum and checking my code for the last 2 days i can't find the problem.

I am using dT 1.10.6 and Editor 1.4.2 (same behavior with Editor 1.4.1)
Link to a test site : http://www.weier.lu/LogoInvent/

The problem is that after a editor window is opend, the export buttons (csv,excel,pdf) remain clickable. This is realy a problem when the editor window covers the buttons, because when i want to click on a form label just over the buttons the click event from the export button is fired....

In the examples on the dT site, the export buttons are not clickable after a editor form opens, just like the new, edit etc. buttons.

In my example the new, edit, copy and delete buttons are not active after a form opens, unfortunately the export buttons are....

Is it a z-index problem or something i missed up? Anyone the same problem or an idea?

Thx a lot for your help.

Yves

This question has an accepted answers - jump to answer

Answers

  • allanallan Posts: 48,908Questions: 1Answers: 7,133 Site admin

    Hi Yves,

    It does indeed appear to be a z-index issue. If you add:

    div.DTED DTED_Lightbox_Wrapper {
      z-index: 100;
    }
    

    to your CSS it should be resolved.

    I will look at addressing this in the upgrades I'm working on.

    Regards,
    Allan

  • zodiacszodiacs Posts: 10Questions: 1Answers: 0

    Hi Allan,

    Thank you for your fast reply.

    I have updated my css file but unfortunately the problem still exists. I have also updated the test case.

    Yves

  • allanallan Posts: 48,908Questions: 1Answers: 7,133 Site admin
    Answer ✓

    Sorry! Typo in my CSS suggestion - it should be:

    div.DTED_Lightbox_Wrapper {
      z-index: 100;
    }
    

    Allan

  • zodiacszodiacs Posts: 10Questions: 1Answers: 0

    Oh yes! Great, it's working perfect now.

    Thank you once again for this quick support.

This discussion has been closed.